MsP Production Blog


Posts Tagged ‘windows xp’

Windows 7 Troubles with the E-MU 0404 PCI Card And How To Fix

Friday, March 5th, 2010

So after my nice little escapade with Pro Tools M-Powered 7.4, and finally being able to get a fix for it (see here for more information), I felt that I no longer needed Windows XP, and decided to make the jump to Windows 7 on my main studio computer.  I’ve been running Windows 7 on my laptop, and was reluctant to upgrade the studio computer in case I needed to run Pro Tools to mix someone else’s stuff.  I currently use Adobe Audition 3.0 right now for all MsP recording needs.

E-MU has the PatchMix system, which is a little app that runs that handles your ASIO.  On Windows XP, there used to be two different visible devices in Windows; one ASIO, and the other a standard wave device.  Usually, most non-audio production stuff would run on the standard wave device E-MU driver, and I would run Audition and FL Studio on ASIO.

However, after installing 7, I ran into an issue: there was only one device, and only ASIO would work, meaning that only my audio production apps had sound.  Everything else, Google Chrome, Media Player, iTunes, etc. would not play.

I thought it was an issue with the driver, but after doing some investigating, I found that Windows itself has a selector for sampling rate.  You need to match this rate with PatchMix.

Here’s a quick screenshot, in case you run into the problem.  Click on it to see it fullsize:

Figure 2010-03-05/1 – PatchMix and Windows 7 Sound Control Panel

Patch Mix and Windows Sound for Windows 7

Notice how both PatchMix and Windows 7 are running on the same sampling rate.  This will allow other Windows apps to use sound.

To get to the Windows 7 Panel you see above:

  1. Take note of what sampling rate PatchMix is using.  If you’re using 44.1K, you will need to set Windows to 44100, i.e.
  2. Hit the Window Logo (The nice circular logo at the bottom left)
  3. Click on Control Panel (On the second column)
  4. Click on Hardware and Sound
  5. Click on Manage Audio Devices
  6. Click on the device that says Speakers, E-MU E-DSP, then click Properties
  7. Click on the Advanced Tab
  8. Choose the appropriate sample rate to match with PatchMix, then hit Apply.
  9. Test by hitting the test button to hear a sound.  If you hear the sound and do not get a “this device is being used by another application” or similar message, you’re good to go.

Growing pains, I tell you.  But at least it’s working!

By the way, thanks to the people who have so far bought tracks from Phase 3 – L.Y.R.I.C.A.L. Without Fear!

Will update soon with a vid or two, MsP news, plus a review on the EastWest Quantum Leap Choir VSTi, as promised!

-mnshyn

BLOG NAVIGATION

TWITTER

FACEBOOK



More MsP on Facebook:
ADM
Black and Blue Ink.
STFU Productions
ADS

Pump Audio Badge